Subject: NetBSD 3.99.15 distribution failure
To: None <>
From: Kenneth Freidank <>
List: current-users
Date: 02/08/2006 07:00:27
Any ideas on what happened?

With 3.0 release as the base, I performed a
    cvs update -A -dP
on either Feb 6 or Feb 7 for /usr/src and /usr/xsrc.

I tarred up the files and moved them to my IBM 1161 laptop, already 
running 3.0 release.

I rebuilt the tools, with no errors.
    ./ -U tools

I rebuilt GENERIC, then enabled PCI BIOS support with a couple of the 
FIXUP flags, and ath* cardbus support.
(I tried GENERIC first, just to ensure it would work, and it did.)
The kernel worked, and so did my DWL-G650 version B5 wireless card!!
    ./ -U kernel=MYKERNEL

I then followed up with...
    ./ -U -u -x distribution
and got the following after several hours..

After the compile line...
    compile dix/events.o
the kernel crashed...
    uvm_fault(0xc0876dc0, 0xc70bc000,0,1)->0xe
    kernel:supervisor trap page fault, code=0
    stopped in pid 17294.1(sh) at netbsd:uvm_unmap_remove to x4d:cmpl 

I tried dmesg...
and after the last line of...
    wsdisplay0: screen....
I got...
    uvm_fault(0xc0876dc0, 0xc70bc000,0,1)->0xe

After a reboot (power down), the df -m says
    /dev/wd0a   3444   2867   404   87%   /
    kernfs            0            0      0   100%   /kern

Is this a hw failure, or something else?