Subject: Re: ide disks missing under 3.99.15
To: Manuel Bouyer <>
From: Daniel Carosone <>
List: current-users
Date: 02/08/2006 07:27:22
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

[I'm Cc:'ing current-users for wider confirmation and testing, this is
not an alpha-specific issue, and leaving extra quoted context accordingly]

On Tue, Feb 07, 2006 at 08:59:12PM +0100, Manuel Bouyer wrote:
> On Tue, Feb 07, 2006 at 08:00:59PM +0200, Arto Huusko wrote:
> > Manuel Bouyer wrote:
> > >On Sat, Feb 04, 2006 at 07:36:25PM +0200, Arto Huusko wrote:
> > >>I tried to upgrade to 3.99.15 (sources updated about Jan 20), but
> > >>neither my custom kernel nor GENERIC find the IDE disk anymore.
> > >
> > >Please make sure you have sys/dev/ic/wdc.c 1.234. If that's not the=20
> > >problem,
> > >try going back to sys/dev/ata/ata.c 1.72
> >=20
> > It still does not work with wdc.c 1.234 and ata 1.73.
> > And the original non-working configuration had
> > wdc.c 1.232 and ata.c 1.72.
> Ha, so it's not my recent changes.  Make sure you have cmdide.c 1.22.

I can confirm something that looks very much like this on i386, with
sil0680 controllers, under xen (and also native).  Up until I saw this
thread, I had been trying to chase it down as a config issue: all the
disks on the other controllers are wired down and probe correctly,
while the remaining wd* devices never appear. I thought that was
somehow related to autoconf changes, but perhaps it is specific to the
sil0680 instead?

Ident of my most recent, still failing tets kernel lists

     $NetBSD: ata.c,v 1.73 2006/01/22 16:40:56 bouyer Exp $
     $NetBSD: cmdide.c,v 1.22 2006/01/17 00:40:49 bouyer Exp $
     $NetBSD: wdc.c,v 1.234 2006/01/24 21:43:26 bouyer Exp $

And an older kernel that failed has:

     $NetBSD: ata.c,v 1.72 2005/12/11 12:21:14 christos Exp $
     $NetBSD: cmdide.c,v 1.22 2006/01/17 00:40:49 bouyer Exp $
     $NetBSD: wdc.c,v 1.232 2006/01/16 20:30:19 bouyer Exp $

If it matters, and the problem is not elsewhere, the working 3.99.9
kernel has:

     $NetBSD: ata.c,v 1.71 2005/07/07 17:51:31 drochner Exp $
     $NetBSD: cmdide.c,v 1.20 2005/09/21 14:32:46 christos Exp $
     $NetBSD: wdc.c,v 1.230 2005/08/29 19:30:07 bouyer Exp $

I haven't had much opportunity to test alternate configs, such as
wiring down more disks on the cmdides, or unwiring all disks yet.
(Rebooting this machine is a little more tedious than most, because
there are several DOMU's running on it.) I'll kick off a kernel build
today with the alternate config and see about testing that soon.

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.4.2 (NetBSD)