Subject: Re: postinstall fixes failed: gid sendmail uid
To: Hauke Fath <hauke@Espresso.Rhein-Neckar.DE>
From: John Nemeth <>
List: current-users
Date: 11/19/2005 13:05:37
On Apr 11,  3:24pm, Hauke Fath wrote:
} At 19:54 Uhr +0200 19.11.2005, Nikos Ntarmos wrote:
} >First, IIRC skipping major versions when upgrading (as in 1.6 -> 3.0) is
} >
} >a bad thing to do.
} Why?

     If this is a problem, then it should be fixed.  However, I'm not
sure it is.  Besides I've seen this particular problem in going from
2.x to 3.x, so it wouldn't have made any difference if the OP had
upgraded to 2.x first.

} What surprises me more is that the OP did not consider running etcupdate(8)
} before postinstall. Since that nicely takes care of updating things that
} may result in conflicts with local changes, I do not really see the need of

     sysinst automatically runs postinstall after unpacking etc.tgz.
It doesn't automatically run etcupdate.

} including an expert system into postinstall.

     Regardless of how it gets done, I'm thinking this problem should
be fixed before release.

}-- End of excerpt from Hauke Fath