Subject: Re: kaffe and/or sable
To: NetBSD-current Discussion List <>
From: Antoine Reilles <>
List: current-users
Date: 11/09/2005 09:15:22
On Nov 9, 2005, at 4:10 AM, matthew sporleder wrote:

> Pkgsrc kaffe and sable seem to be a little out of date, so I tried
> installing kaffe or sable myself.
kaffe in current pkgsrc is 1.1.6, which is the latest stable release.
It should ork quite well on netbsd, except for a few problems with  
threads, that are being tracked by the kaffe team.
Of course, it is not as new as the current kaffe cvs, but for what i  
tried recently, kaffe cvs it not as much stable compared to 1.1.6
> Basically, I got jikes and gnu classpath to compile without any
> issues, but kaffe doesn't work because boehm-gc doesn't seem to
> support our threading,
yes, you will have to use kaffe-gc. I whould like to use pkgsrc boehm- 
gc in kaffe, but it is quite difficult to setup

> and I can't get sablevm to find libltdl.  I'll
> admit that I'm not the best at compiling, but I was wondering if
> anyone else had tried this.

I will try to update sooner or later jikes and classpath, but do not  
expect it this week