Subject: Re: Getting repeatedly the same compile error with groff.
To: None <>
From: Ja'far Railton <>
List: current-users
Date: 11/07/2005 19:30:02
On Mon, Nov 07, 2005 at 03:06:59PM +0100, Marcin Jessa wrote:
> Hi guys.
> I really do not know why but I allways get this error running 
> ./ -O /usr/obj -T /usr/tools distribution
> on freshly installed boxes. It's been like that for many months.
> This one was installed from CURRENT (3.9.7) iso and the sources are
> updated to 3.9.11.
> And yes, I created tools running ./ -O /usr/obj -T /usr/tools
> tools
> #    create  eqn/eqn.d
> CC=/usr/tools/bin/i386--netbsdelf-gcc /usr/tools/bin/nbmkdep -f eqn.d
> --   -DHAVE_CONFIG_H -I/usr/src/gnu/dist/groff/src/include
> -I/usr/src/gnu/usr.bin/groff/src/include  -nostdinc++
> -isystem-cxx  /usr/obj/destdir.i386/usr/include/g++    -nostdinc
> -isystem /usr/obj/destdir.i386/usr/include
> eqn.cpp /usr/src/gnu/dist/groff/src/preproc/eqn/eqn.y:27:17: box.h: No
> such file or directory nbmkdep: compile failed.

I was getting the same error when building distribution from netbsd-2
sources. I tried again using a minimal mk.conf [1] and the build
completed. Hope this helps.

- j

% uname -mr
3.0_BETA i386

#CPUFLAGS=-march=pentium3 -mmmx -msse -mfpmath=sse
#CFLAGS=-O2 -pipe

Ja'far ibn Richard Railton