Subject: Re: preliminary port of some ath tools
To: Chavdar Ivanov <>
From: Steven M. Bellovin <>
List: current-users
Date: 10/24/2005 18:15:48
In message <>, Chavdar Ivanov writes:
>80211watch seems to work fine on my laptop with -current from about
>two days ago; the driver in use is ral. It generally works solid when
>no WPA is enabled (could never get WEP working using ifconfig, should
>have tried wpa_supplicant). With WPA it tends to become offline ever
>so often and fail to negotiate the keys again (not always, but often
>enough; I couldn't figure out much from the wpa_supplicant -ddd log).
>Today I ran it for about eight hours with WPA while 80211watch was
>running, hoping to get some useful info as to why this happens, but it
>never failed...

Hmm -- I *hope* it isn't a race condition....

Anyway, I've updated 80211debug; it should work, too.  But all I have 
is an ath card; please see if '80211debug -i ral0' works.  I probably
won't bother getting 80211stats working since 'ifconfig -v' gives about
the same output.

		--Steven M. Bellovin,