Subject: Re: preliminary port of some ath tools
To: Steven M. Bellovin <>
From: Chavdar Ivanov <>
List: current-users
Date: 10/24/2005 21:57:12
80211watch seems to work fine on my laptop with -current from about
two days ago; the driver in use is ral. It generally works solid when
no WPA is enabled (could never get WEP working using ifconfig, should
have tried wpa_supplicant). With WPA it tends to become offline ever
so often and fail to negotiate the keys again (not always, but often
enough; I couldn't figure out much from the wpa_supplicant -ddd log).
Today I ran it for about eight hours with WPA while 80211watch was
running, hoping to get some useful info as to why this happens, but it
never failed...

2005/10/24, Steven M. Bellovin <>:
> I've ported a few of the FreeBSD tools for ath and 802.11 monitoring.
> Testing thus far has been minimal.  You can find them at
>  I have not attempted
> to figure out where they should fit in our source tree, nor do the
> #include files reflect any location in the tree.  My testing was
> done on 3.99.9 from about a month ago.
> 80211debug has a problem with its sysctls; I neither know what
> it's trying to accomplish nor do I know what a % in sysctlbyname means
> in that version of FreeBSD.  (I can probably figure it out now that
> I'm back online, but I did my work on a airplane...)  80211stats
> has lots of undefined symbols, and I haven't found where, if anywhere,
> NetBSD keeps its equivalents.  It's possible that 'ifconfig -v'
> subsumes it.