Subject: FOLLOWUP: Re: building -current for macppc (still) fails in ofwboot
To: Havard Eidnes <>
From: Timo Schoeler <>
List: current-users
Date: 10/18/2005 19:37:21
>>>>removing the 'static' declaration from startup and setup in
>>>>Locore.c fixes the problem.
>>>The strange thing is that this does not cause a build problem in
>>>my case:
>>just out of curiosity -- could you post the dmesg of the machine?
> The host I'm building on is running NetBSD/i386 2.0_STABLE, but
> all the tools are of course set up to do cross-compilation, so I
> don't see how that would be relevant?

i tried this on an NetBSD/i386 2.0.2_RELEASE for months now and it never
built okay. it always crashed in ofwboot (Locore.c). of course i made
sure to have the obj files extinguished before, i usually check out
freshly from CVS.

neither crossbuilding from i386 nor a native build in macppc came
trough; on the latter i tried 2.0_RELEASE as well as 2.0.2_RELEASE ,
3.0_BETA, and 3.99.9. no success.

*** <followup> ***

it's sure that the i386 host has *no* memory errors. it's a production 
machine and as i'm always sceptical on that plan i386 stuff it's 'server 
grade hardware', i.e. features ECC.

furthermore the G4 -- although it doesn't feature ECC -- is surely okay. :)

*** </followup> ***

>>>What versions of gcc and ld do you use when building?  Cross-
>>>reference with what I use, see above.
>>they're exactly the same.
> Hm, then I think I'm out of ideas about what this problem is.

okay, seems to be the same as when the MCHK issue came up... weird.