Subject: Re: unattended cdboot
To: Bang Jun-Young <>
From: David Young <>
List: current-users
Date: 08/18/2005 15:38:57
On Wed, Jul 20, 2005 at 02:27:12PM +0900, Bang Jun-Young wrote:
> > I think it is a reasonable compromise for all of our needs, if the
> > keypress is configurable with, say, an installboot(8) option.
> It's not possible to install cdboot to CD-ROM by using installboot
> since CD-ROM is read-only media.

One would installboot to the CD-ROM image before recording the CD-ROM.
I run installboot(8) on Compactflash images all of the time.


I just tried to boot an ISO9660 filesystem created by makefs like so:

% $TOOL_MAKEFS -x -F $DESTDIR/metalog.image -N $INSTDIR/etc -t cd9660 \
    -o "rockridge,bootimage=i386;$DESTDIR/usr/mdec/cdboot,no-emul-boot"\

The CD-ROM would boot neither qemu nor a laptop.  On the laptop, it
complained that it could not find /boot (/boot is in there!).  On qemu,
I do not see any progress after cdboot displays its banner.  If you will
contact me privately, I will provide you with the ISO image.


David Young             OJC Technologies      Urbana, IL * (217) 278-3933