Subject: Re: ath and/or net80211 troubles
To: None <,>
From: Jukka Salmi <>
List: current-users
Date: 07/11/2005 00:40:35
Jukka Salmi --> current-users (2005-07-09 20:37:27 +0200):
> Hi,
> using today's HEAD sources on a Soekris net4511 (acting as an access
> point) and a IBM ThinkPad X40 I'm seeing (probably) net80211 or ath
> related problems. The net4511 has a 3com cardbus ath card (3CRPAG175),
> the ThinkPad uses a miniPCI ath card.
> As soon as the laptop starts to download a large file through the AP,
> the AP becomes very unresponsive; e.g. `ls' sometimes takes more than
> a minute to return, even when run in an empty directory. Sometimes the
> AP even reboots, probably because the watchdog timer expired (at least
> I never saw a reboot after I disarmed the timer).
> I already tried a kernel from before the latest net80211/ath import from
> FreeBSD on the AP, but the problem was still the same. However, I don't
> have an older kernel for the laptop to test right now (anybody has a i386
> GENERIC_LAPTOP available from before the import?).

I had a closer look at the problem. First of all I noticed the problem
only occurs when using 11a or 11g and the net4511 in hostap mode. Using
11b with hostap mode and 11[abg] with adhoc mode works fine.

I built kernels for both devices (net4511 and laptop) from sources before
and after the latest net80211/ath import, and tried all four possible
combinations. All of them made the router (net4511) reboot some seconds
after a file transfer (fetching a large file via http using ftp(1) from
a machine behind the router) was started on the laptop. The watchdog timer
period was 16 seconds (three of the four combinations even made it reboot
if the timer period was 32 seconds).

> When running another OS on the laptop, I don't see this problem, i.e.
> the AP is responsive even while the laptop generates massive traffic.

This "other OS" is XP, by the way.

> Comments and hints about how to debug this problem are appreciated.

Still true...

TIA, Jukka

bashian roulette:
$ ((RANDOM%6)) || rm -rf ~