Subject: Re: wscons, german keymap, X11 gone wild.
To: Martin S. Weber <>
From: Martin Husemann <>
List: current-users
Date: 07/09/2005 11:11:48
Ok, I updated my i386 notebook and it mostly works for me (see below). I
probably misunderstood something about your problem, or something is
different in my setup.

I have this in my XF86Config:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc102"
        Option      "XkbLayout" "de"
        Option      "XkbVariant" "nodeadkeys"

and this in my kernel config:

options         PCKBD_LAYOUT="(KB_DE | KB_NODEAD)"

Everything works just fine, besides two minor issues

(1) in X, the unshifted variant of ` does not produce the other french
accent, but ? instead. The output of xmodmap -pk looks ok:

        21         0x00b4 (acute)  0x0060 (grave)  0x00b8 (cedilla) \
	       0x00b8 (cedilla)        0x00b8 (cedilla) \
	               0x00b8 (cedilla)        

and xev shows:

KeyPress event, serial 32, synthetic NO, window 0x2200001,
    root 0x60, subw 0x0, time 7523748, (77,66), root:(895,126),
    state 0x0, keycode 21 (keysym 0xb4, acute), same_screen YES,
    XLookupString gives 1 bytes: (b4) "Ž"
    XmbLookupString gives 1 bytes: (b4) "Ž"
    XFilterEvent returns: False

but my locale (de_DE.ISO8859-15) does not seem to like this code.
On console this works better, but I get ' there as symbol, not the real

(2) on console the AltGr-e key combination does not produce the EUR symbol,
which works fine inside X.