Subject: Re: pccbb disabling sockets because of "bad Vcc request"?
To: Peter Seebach <>
From: Greg Troxel <>
List: current-users
Date: 06/29/2005 21:41:11
  I have a ThinkPad whose cardbus sockets used to work, maybe a year ago.
  I haven't noticed them in months, because the machine's mostly
  self-sufficient, but I tried to put in a USB controller, and it didn't work.

  cbb1: bad Vcc request. sock_ctrl 0xffffff88, sock_status 0xffffffff

I had similar trouble with the cardbus controller on a Thinkpad 600E
(2645-4AU), and fixed it by changing the RBUS_MIN_START value.  I'm
slightly fuzzy, but basically cardbus space is mapped somewhere, and
the default was IIRC 1 GB.  On the 600E, that fails in a similar way,
and I think only the first 1 GB of addressing works somehow.  Mapping
at 0.5 GB works ok.  In your case, you should try moving
RBUS_MIN_START to 2.5 GB, to get it away from real memory.  But take
with a gr of salt.  This could be more automatic now, and I didn't
deeply understand this.

        Greg Troxel <>