Subject: VIA SATA problem
To: NetBSD current <>
From: Michal 'hramrach' Suchanek <>
List: current-users
Date: 06/22/2005 16:52:40

I tried to install NetBSD on a machine with hardrive attached to a VIA
SATA controller. The setup fails during newfs. 

So I tried to install to a disk connected to PATA and newfs from the
newly installed system running GENERIC.MPACPI

I first tried dd if=/dev/wd0d of=/dev/null for a while and running
Then I tried newfs on /dev/wd0a and it failed:

3.99.6 NetBSD 3.99.6 (GENERIC.MPACPI) #0: Fri Jun 17 07:32:00 CEST 2005 i386

VIA Technologies VT6306 IEEE 1394 Host Controller (Firewire serial bus,
interface 0x10, revision 0
x46) at pci0 dev 14 function 0 not configured
viaide0 at pci0 dev 15 function 0
viaide0: VIA Technologies VT8237 SATA Controller (rev. 0x80)
viaide0: bus-master DMA support present
viaide0: primary channel wired to native-PCI mode
viaide0: using ioapic0 pin 20 (irq 10) for native-PCI interrupt
atabus0 at viaide0 channel 0
viaide0: secondary channel wired to native-PCI mode
atabus1 at viaide0 channel 1
wd0 at atabus0 drive 0: <Maxtor 6Y200P0>
wd0: drive supports 16-sector PIO transfers, LBA48 addressing
wd0: 189 GB, 395136 cyl, 16 head, 63 sec, 512 bytes/sect x 398297088
wd0: 32-bit data port
wd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 6 (Ultra/133)
wd0(viaide0:0:0): using PIO mode 4, Ultra-DMA mode 6 (Ultra/133) (using
viaide0:0:0: lost interrupt
        type: ata tc_bcount: 16384 tc_skip: 0
viaide0:0:0: bus-master DMA error: missing interrupt,
viaide0:0:0: device timeout, c_bcount=16384, c_skip0
wd0a: device timeout writing fsbn 18432256 of 18432256-18432287 (wd0 bn 18432319; cn 18286 tn 0 sn 31), retrying
wd0: soft error (corrected)
After that newfs always fails and it appears it never tries to write the
sector again.


Michal Suchanek