Subject: Pam and Current
To: NetBSD-current <>
From: Marcin Jessa <>
List: current-users
Date: 06/22/2005 15:21:10

I was wondering about changes made in Current.
There seems to be some changes in pam that I was not aware of. 
I created a mini NetBSD version for embedded boxes. It all works fine with 2.0 kernel and bins compiled for it.
But on current I get different library dependiences for the binaries. 
Also on 3.99.6 login tells me:
login: pam_start failed

Are the additional lib dependiences of 2.x replaced by pam on 3.99.6?

On 3.99.6 :

ldd login
         -lutil.7 => /usr/lib/
         -lcrypt.0 => /usr/lib/
         -lpam.0 => /usr/lib/
         -lc.12 => /usr/lib/

On 2.0:
ldd login
         -lutil.7 => /usr/lib/
         -lcrypt.0 => /usr/lib/
         -lskey.1 => /usr/lib/
         -lkrb5.19 => /usr/lib/
         -lasn1.6 => /usr/lib/
         -ldes.7 => /usr/lib/
         -lkrb.6 => /usr/lib/
         -lcrypto.2 => /usr/lib/
         -lroken.12 => /usr/lib/
         -lcom_err.4 => /usr/lib/
         -lc.12 => /usr/lib/