Subject: Re: MBR boot fails on AMD 64 (infinite loop)
To: None <>
From: Andy Ruhl <>
List: current-users
Date: 05/25/2005 08:24:55
On 5/25/05, Vincent <> wrote:
> Hi again,
> I (more or less) succeeded in installing an AMD64-current (3.99.4)
> distrib on the workstation HP loaned me for a while. The nVidia nForce 4
> chipset is not very well handled, but that's not a big problem.
> However, I have failed to properly boot the machine. Just after boot, it
>   simply keeps looping on a 'NetBSD MBR boot' message that it displays
> at libidum. Nothing to do. I've tried to tinker with the various boot
> files, no success so far.
> Has anybody any idea ? The disk drives are two SCSI drives, they appear
> as sd0 and sd1 during install, and every partition can be mounted and
> read by the INSTALL kernel.

I have an AMD64, but it's an Abit motherboard. I was having some
problems too, but they may not be related.

But the fix may be related: I found that fdisk was broken and wasn't
allowing me to set the boot partition correctly, and the boot list at
boot time was wrong. I'm not really too good at knowing the insides of
the boot process so I can't really explain it.

The fix was to use an install CD from 1.6, and then re-do the
partition "labels" with fdisk -B, then do installboot just like it
says in the example for an i386 machine (AMD64 should be the same).

It worked.