Subject: ftp to ip+ipv6 fail [Re: ftp 3.0_BETA -> 2.0 fail]
To: None <>
From: Manuel Bouyer <>
List: current-users
Date: 05/25/2005 12:12:39
On Wed, May 25, 2005 at 11:36:19AM +0200, Manuel Bouyer wrote:
> Hi,
> I installed the 200505130000Z 3.0_BETA snapshot on a i386 box.
> >From this box ftp to a 2.0 server (I tried 3 different ftp servers) fail
> with:
> lavardin# ftp -a antioche
> Trying 2001:660:3302:282a:204:75ff:fe9f:9e11...
> ftp: connect to address 2001:660:3302:282a:204:75ff:fe9f:9e11: Unknown error: 6448
> Trying
> ftp: connect: Unknown error: 3768
> a ktrace shows that connect returned error 36 (Operation now in progress)
> (so ftp doesn't print the right error message, in addition to getting an
> error message when it shoudln't).
> ftp to any other servers (including NetBSD 1.6.2) works.

It happens that all the 2.0 servers I tried have A and AAAA records, and
all others have only A records. If I use an IP, or a name which has either
a A or AAAA record only, it works. So the issue isn't with the server
version, but with DNS names which points to both v4 and v6 addresses.

Manuel Bouyer <>
     NetBSD: 26 ans d'experience feront toujours la difference