Subject: addicmp.o error while building release
To: None <>
From: Alessandro Manunza <>
List: current-users
Date: 05/17/2005 01:42:28
Hello all, 

I installed binaries of  release 20050506 ( kernel-GENERIC.tgz, bese.tgz,
comp.tgz, etc.tgz).
So I have NetBSD 3.0_BETA (GENERIC). Than I update /usr/src with -current
with cvs:

export CVSROOT=""
cvs update -dP

I ./ a "release" and I get this error:

#   compile  libipf/addicmp.o
/usr/src/../tools/bin/i386--netbsdelf-gcc -O2 -Wall -Wstrict-prototypes
-Wmissing-prototypes -Wpointer-arith -Wno-sign-compare -Wno-traditional
-Wno-uninitialized  -Werror    -I/usr/src/dist/ipf -I/usr/src/dist/ipf/tools
-I/usr/src/sys -I/usr/src/sys/dist/ipf -I/usr/src/sys/dist/ipf/netinet
-DSTATETOP -D__UIO_EXPOSE   -nostdinc -isystem
/usr/src/obj/destdir.i386/usr/include -c    /usr/src/dist/ipf/lib/addicmp.c
-o addicmp.o.tmp

*** Failed target:  addicmp.o
*** Failed command: /usr/src/../tools/bin/i386--netbsdelf-gcc -O2 -Wall
-Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wno-sign-compare
-Wno-traditional -Wno-uninitialized -Werror -I/usr/src/dist/ipf
-I/usr/src/dist/ipf/tools -I/usr/src/sys -I/usr/src/sys/dist/ipf
-I/usr/src/sys/dist/ipf/netinet -DSTATETOP -D__UIO_EXPOSE -nostdinc -isystem
/usr/src/obj/destdir.i386/usr/include -c /usr/src/dist/ipf/lib/addicmp.c -o
*** Error code 1

nbmake: stopped in /usr/src/usr.sbin/ipf/libipf

*** Failed target:  dependall
*** Failed command: cd /usr/src/usr.sbin/ipf/libipf;
/usr/src/../tools/bin/nbmake realall
*** Error code 1

nbmake: stopped in /usr/src/usr.sbin/ipf/libipf

*** Failed target:  dependall-libipf
*** Failed command: _makedirtarget() { dir="$1"; shift; target="$1"; shift;
case "${dir}" in /*) this="${dir}/"; real="${dir}" ;; .)
this="usr.sbin/ipf/"; real="/usr/src/usr.sbin/ipf" ;; *)
this="usr.sbin/ipf/${dir}/"; real="/usr/src/usr.sbin/ipf/${dir}" ;; esac;
show=${this:-.}; echo "${target} ===> ${show%/}${1:+ (with: $@)}"; cd
"${real}" && /usr/src/../tools/bin/nbmake _THISDIR_="${this}" "$@"
${target}; }; _makedirtarget libipf dependall
*** Error code 1


*** Failed target:  release

I tried many others combinations and solutions but get always the same error
with the addicmp.o target ( I verified  that the
/usr/src/dist/ipf/lib/addicmp.c is in the correct path).

Any help is welcomed.

Thank you, sorry for my English and sorry if the question stupid, I'm a
newbie in NetBSD (I was Slack-er)   

Alessandro Manunza, Italy