Subject: Re: mount_smbfs problems
To: Justin Newcomer <>
From: Andy Ruhl <>
List: current-users
Date: 05/09/2005 13:36:26
On 5/9/05, Justin Newcomer <> wrote:
> hello
> I have been running the -current kernel for some time now, (cross
> compiling is wonderful)
> and I want to be able to mount smb shares on other boxes (windows 2003 se=
> the problem is...
> mount_smbfs //user@server/images /mnt/smb
> Password:
> mount_smbfs: can't get handle to requester (no /dev/nsmb* device availabl=
> I tried
> 04:19:01 /dev # ./MAKEDEV nsmb
> ./MAKEDEV: nsmb0: unknown device
> ./MAKEDEV: nsmb1: unknown device
> ./MAKEDEV: nsmb2: unknown device
> ./MAKEDEV: nsmb3: unknown device
> so I tried to recompile the kernel with
> file-system     SMBFS
> pseudo-device   nsmb
> but I still get the exact same problem
> the mailing lists has had this problem before, but I couldnt find
> anyone who actually solved the problem
> If there is something I am missing or its just not going to work or
> anyone has any ideas
> any input would be greatly appreciated

You have to know how to build the device files. I believe the MAKEDEV
script isn't doing it right, and I'm not smart enough to know how to
do it right. But if you find out, that would be great for everyone to
know. I'd like to do that with mine once in a while too.