Subject: Re: trouble with 10baseT autoselect on wm0
To: Tom Ivar Helbekkmo <>
From: Steven M. Bellovin <>
List: current-users
Date: 04/27/2005 22:22:46
In message <>, Tom Ivar Helbekkmo writes:
>"Steven M. Bellovin" <> writes:
>> I have a Thinkpad T42 with a wm GigE card.  I've never tried it at
>> GigE speeds; it runs fine at 100 Mbps.  But it doesn't work at 10
>> Mbps if I have it set to 'media autoselect'.  However, if I set it
>> to 'media 10baseT', it works.
>I have one of those laptops as well.  I haven't tried it at 10 Mbps,
>but I had to quit letting it autoselect against our Cisco GigE capable
>switch, because it would negotiate 1 Gbps and full duplex -- after
>trying for about two minutes.  Every time something happened to the
>interface, such as me putting it into promiscuous mode with tcpdump,
>there would be another two minute wait for the autoselect.

Hmm -- I haven't tried waiting two minutes...  But I've seen a number 
of postings that suggest that disabling autonegotiation is a bad idea, 
because some devices can't work any other way.

		--Prof. Steven M. Bellovin,