Subject: Re: problems writing to USB stick
To: None <>
From: Jukka Salmi <>
List: current-users
Date: 04/21/2005 13:51:59
Christoph Kaegi --> current-users (2005-04-21 13:44:34 +0200):
> On 21.04-01:24, Jukka Salmi wrote:
> > Hello,
> > 
> > on a current (3.99.3) i386 system, while extracting binary sets to FFS
> > on a USB flash drive, the write process (I used tar and pax) often hangs
> > for several minutes (sometimes up to ten) at random places; ps reports
> > state `D'. The system in use:
> > 
> Did you enable softdeps when mounting the filesystems on the USB 
> flash drive?
> If yes, try without softdeps.

No, I don't use softdeps.

BTW, I just tried again, and writing with pax succeeded without any
problems; then I newfs-ed the flash drive, and tried again with tar.
After writing some files, the system hung and did not recover anymore,

	umass0: BBB reset failed, TIMEOUT
	umass0: BBB bulk-in clear stall failed, TIMEOUT

for about half an hour until I pressed the reset button... But pax working
and tar not was probably a coincidence.

Regards, Jukka

bashian roulette:
$ ((RANDOM%6)) || rm -rf ~