Subject: Re: resetting USB ports?
To: Steven M. Bellovin <>
From: Richard Rauch <>
List: current-users
Date: 04/12/2005 16:19:30
I would rather suggest *disabling* IOAPIC.

I saw exactly your problem on my AMD64 box a year ago or so.  Somewhere,
I got the hint of disabling IOAPIC (I never turned on MPACPI).  The problem
went away.

That doesn't prove that it's the same cause but the symptoms were the same.
The mouse would attach and work for a while, then it would die at some
random later time while the system was in use.  (I believe that the whole
USB port went south.)  This was on a motherboard using an nVidia nForce3
chipset; others (at least with older nForce3 chipsets) reported similar

(Actually, depending how I had my PCI cards juggled, I recall that sometimes
the mouse would be okay, but some other devices would fail to configure.  The
last time that I tried a GENERIC kernel (i.e., with IOAPIC), I still had the
problem.  I've tried MPACPI, but didn't keep it; I can't remember exactly
what didn't work with it.  My faint memory is that the problem was the same
as with IOAPIC.)

It might even be worth while removing, or relocating, any PCI cards you

Just a thought.

  "I probably don't know what I'm talking about."