Subject: Re: bce and iwi problems
To: None <>
From: Christos Zoulas <>
List: current-users
Date: 04/07/2005 08:56:49
In article <>,
Hitoshi Asaeda  <> wrote:
>I've installed netbsd-current on ThinkPad X40 and Dell Inspiron 8600
>these days. 
>Netbsd on X40 recognizes its wireless interface as iwi0, but when I
>run "dhclient iwi0", it says "ifconfig: SIOCAIFADDR: Input/output
>error" and "iwi0: not found", and hence I cannot enable this
>I used GENERIC_LAPTOP for the kernel generation and everything was
>built last week.

Did you load the firmware? You need to install sysutils/iwi-firmware
from pkgsrc, and then load the firmware with iwictl.

>On the other hand, netbsd on Inspiron 8600 recognizes its ethernet as
>bce0, but the kernel always shows "bce0: data error" on the console.
>I tried GENERIC and GENERIC_LAPTOP for the kernel generation but there
>is no difference for this bce problem.
>Actually when I used this machine with netbsd-2.0, bce0 worked.
>Any idea?
>p.s. If you have any information to enable wireless interface on
>Inspiron, I'd happy to hear it, too. Thanks.

There was a recent commit on the OpenBSD mailing lists that fixed
an interrupt conflict issue in one of the ethernet drivers, maybe