Subject: Re: Password for su no more required after upgrade !
To: Steven M. Bellovin <>
From: Dunric <>
List: current-users
Date: 01/17/2005 15:29:31
> Od: "Steven M. Bellovin" <>
> Komu: "Dunric" <>
> CC:
> Datum: Mon, 17 Jan 2005 09:53:40 -0500
> Předmět: Re: Password for su no more required after upgrade !
> In message <S1339023AbVAQNtU/>, "Dunric" 
> writes:
> >I upgraded NetBSD 2.0 to current from sources and now any user can su
> >to root without a password.
> >Yep, I've read /usr/src/UPDATING, I've run postinstall -s /usr/src -d
> >/ fix. Postinstall was unable to fix x11 config files only.
> >After postinstall and etcupdate I've found /etc/pam.d remains empty so I tried
> >to copy manualy pam config for su from /usr/src/etc/pam.d but it
> >solved nothing :-(
> >
> >What have to be done for authentication to be working again ?
> >
> >
> >Thx in advance
> >
> That sure sounds like root no longer has a password.  You can check 
> that by looking at /etc/master.passwd, or simply setting a new password 
> for root.
>   --Prof. Steven M. Bellovin,

Unfortunately root has password. I even tried make a new password and recreated password databases with pwm_mkdb :(
I think it has something to do with su is using(linked against) PAM library now. I never used pam before so I'm now unable simply track down source of the problem.

Any help appreciated