Subject: recent problems compile xorg-libs under -current
To: None <>
From: Harry Waddell <>
List: current-users
Date: 01/02/2005 22:42:03
I've been trying to get update to xorg-libs-6.8.1nb4 on two of my i386-current 
systems, but some things aren't getting built because of some problems with some 
thread defs in the include files:

/usr/include/threadlib.h:154: error: conflicting types for `__libc_thr_yield'
/usr/include/sched.h:67: error: previous declaration of `__libc_thr_yield'

Before I dig into this more deeply, have any of -current folks seen the same
problem, or alternately succeeded in compiling this package recently?
It builds just fine with netbsd-2.0. 

Harry Waddell
Caravan Electronic Publishing