Subject: Can't mount an UMASS device
To: None <>
From: Claudio M. Camacho <>
List: current-users
Date: 12/13/2004 13:10:52
   Hi again.

   I've tried to mount a MemoryStick Card with a normal USB 2.0 Memory
Card Reader attached to ehci(uhci). The thing is that the device is
recognized quite well, and SCSIVERBOSE plus USBVERBOSE show me all the
info about sd0, sd1 and sd2 detected (all the LUNs in the single

   I use NetBSD 2.9.11 (src from 20041210), I have an i386 (Pentium
Mobile Centrino).

   The problem comes when I try to mount the device:

	root~# mount -t msdos /dev/sd1b /mnt
	sd1: fabricating a geometry
	mount_msdos: /dev/sd1b on /mnt: Device not configured
   Straight away after this, when I try to mount again, it only says:

	root~# mount -t msdos /dev/sd1b /mnt
	mount_msdos: /dev/sd1b on /mnt: Device not configured

   I guess there's some problem with the umass, cause it tries to mount
the device, but it cannot. These are the related options I have in my
kernel config file:

	options		USBVERBOSE

	scsibus*	at scsi?
	sd*		at scsibus? target ? lun ?

	ehci*		at pci? dev ? function ?
	uhci*		at pci? dev ? function ?

	usb*		at ehci?
	usb*		at uhci?
	uhub*		at usb?
	umass*		at uhub? port ? configuration ? interface ?
	scsibus*	at umass?
	wd*		at umass?

   I have no clue. As I got some problems with my EHCI mouse and APM, I
tried with all these choices:


   But I get the same results...

   Anyone with this problem?