Subject: Re: unbootable new disk?
To: current-users <>
From: Robert Nestor <>
List: current-users
Date: 11/26/2004 22:02:13
On Nov 26, 2004, at 8:26 PM, Steve Bellovin wrote:

> I received a private note that mentioned similar problems -- but moving
> the drive to another machine solved the problem.  The author's
> conclusion was that it was likely some unknown BIOS bug.
> I changed the BIOS setting for the disk to LBA, from "Auto" (the other
> choices were "Large" and "C/H/S"); after that, it worked just fine.

I recently bought a 160Gig disk and noticed it came with a warning that 
under some versions of Window and Mac OS the disk may only show 137Gig. 
  When I tried it on an early version eMac I didn't see any size 
limitations, but when installed in a T4155 eMachine it showed only 
137Gig - both in the BIOS display and under Windows-XP.  (There was a 
patch for Windows that would get around this problem.)  However 
NetBSD-2.0H showed the full 160Gig on this same system!  I did have 
some difficulty getting NetBSD set up so that it would boot from this 
disk when I used sysinst.  I attributed my boot problems to operator 
error and changes to sysinst, fdisk and the MBR that I wasn't prepared 
for - having done a number of installations previously I figured I 
didn't need to read the INSTALL documentation. (I'm sure I'm the only 
user who ever made that simple mistake!)

I played with the LBA/CHS/Auto parameter in my BIOS setup and finally 
got a working configuration.  Unfortunately I didn't play close enough 
attention to discover any relationship between BIOS setup and what I 
was seeing in NetBSD (or Windows).  This BIOS parameter seems to have 
some effect on getting NetBSD running correctly, but the setting is 
probably dependent on the type or version of BIOS the system has.  (I 
think Steve found that the LBA setting was necessary on his system; on 
mine I think it required an Auto setting.)

Based on the wording of the "137Gig Limit" that came with this disk, 
what I was able to find on the subject online from various disk 
manufacturers and what I saw with two different disks on this system, I 
suspect the 137Gig limitation is partially a BIOS problem and partially 
an OS problem.  Some Operating Systems are able to work around the 
limitation in a transparent manner and some require patches.  Different 
BIOS implementations may approach the problem differently and it may be 
difficult to identify a simple solution that works in all cases.