Subject: Re: unbootable new disk?
To: None <>
From: Steve Bellovin <>
List: current-users
Date: 11/26/2004 21:26:08
I received a private note that mentioned similar problems -- but moving 
the drive to another machine solved the problem.  The author's 
conclusion was that it was likely some unknown BIOS bug.

I changed the BIOS setting for the disk to LBA, from "Auto" (the other 
choices were "Large" and "C/H/S"); after that, it worked just fine.

Looking back at my postings I see this:

# fdisk wd1
Disk: /dev/rwd1d
NetBSD disklabel disk geometry:
cylinders: 310101, heads: 16, sectors/track: 63 (1008 sectors/cylinder)
total sectors: 312581808

BIOS disk geometry:
cylinders: 1024, heads: 240, sectors/track: 63 (15120 sectors/cylinder)
total sectors: 268435455

Why do the BIOS and NetBSD number of sectors disagree?  The same is 
true now, with the system running.  Yes, it's a 160G drive, but I have 
a 160G drive on another machine, and the two geometries give the same 
total on it.  Is this some BIOS limitation in dealing with a large 
drive?  And might that have been at the root of my problem?

		--Steve Bellovin,