Subject: Re: Perl 5.8.5 continue without work in RC4 and recent pkgsrc
To: Francisco Valladolid <>
From: Gavan Fantom <>
List: current-users
Date: 11/19/2004 11:49:36
On Thu, 18 Nov 2004, Francisco Valladolid wrote:

> Hi, Today by the morning I update my pkgsrc treee, and I been using NetBSD
> RC4, when I try to install perl.5.8.5 the make program exit with the next
> message.
> ===> Checking for vulnerabilities in perl-5.8.5nb2
> ===> Building for perl-5.8.5nb2
> `sh  cflags "optimize='-O2 -pthread -I/usr/include'" pp_sys.o` -DPIC -fPIC
> pp_sys.c
> *** Error code 1

Try installing the gmake package. I've been seeing this error too, and it 
appears to be something broken in dependency handling.

Could you please post the contents of /etc/mk.conf, in particular whether 
you have set USE_PKGSRC_GCC, GCC_REQD, or anything else that could 
affect the choice of compiler in use.

Please also let us know if installing gmake worked around the problem.

Gillette - the best a man can forget