Subject: Re: ipnat is broken in 2.0RC4
To: None <>
From: Patrick Welche <>
List: current-users
Date: 11/12/2004 19:44:02
On Wed, Oct 20, 2004 at 03:10:06PM +0100, Patrick Welche wrote:
> On Wed, Oct 13, 2004 at 03:25:07PM +0100, Patrick Welche wrote:
> > On Wed, Oct 13, 2004 at 01:00:05PM +0000, Jari Kuittinen wrote:
> > > I had ipnat happily running on my 2.0_BETA box. It worked perfectly over
> > > 100 days until it just suddenly stopped working. I tried restarting
> > > everything and clearing nat rules, but it didn't help. Since i had to
> > > reboot i upgraded to 2.0_RC4, which worked only for _2_ days and i had
> > > to reboot once again.
> > > 
> > > I'm running NetBSD i386 with custom kernel (only useless device drivers
> > > removed from generic)
> > 
> > I hate to say "me too" but that's all I have - no diagnostic anything..
> > Trying yesterday's current now to see if it improves things..
> It was all looking hopeful, but now 3 freezes in 24h. No panic, nothing
> on the console other than ipmon info, CPU fan still going... I suppose
> its time to get last years code, 6 months ago etc.

So, replacing the -current/i386 code of 13 October 2004 with code from
15 October 2003 has "fixed" this firewall/nat box. On Monday it will be
3 weeks that it has been up continuously.

(i.e., same hardware, same ipf.conf, same ipnat.conf, same network)

Now this suggests that something is up with the code, but I can't be the
only one running ipf/ipnat on i386, and no one else is clamouring about
mysterious freezes. On top of it, following the sparc64 and ftp proxy
thread, you all seem to use i386 as the working standard.

Curiouser and curiouser..