Subject: Re: Using Xfree86's "current" sources for xsrc
To: I'Khala <>
From: Louis Guillaume <>
List: current-users
Date: 11/05/2004 18:29:35
I'Khala wrote:

> Hello,
> 1st, did you check the docs/manual/cdrom that came with the optiplex
> to see what video h/w it has?  Also check the output of 
> "dmesg|grep vga0".

The problem isn't with NetBSD...

$ dmesg|grep vga0
vga0 at pci0 dev 2 function 0: Intel 82915G/GL Integrated Graphics 
Device (rev. 0x04)
wsdisplay0 at vga0 kbdmux 1: console (80x25, vt100 emulation)

... but with the X distribution. The xsrc version (4.4.0) doesn't work 
with my hardware (doesn't provide a specific driver) but this does...

$ X -version

This is a pre-release version of XFree86, and is not supported in any
way.  Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org.  Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository

XFree86 Version
Release Date: 27 October 2004
X Protocol Version 11, Revision 0
Build Operating System: NetBSD/i386 2.99.10 [ELF] The NetBSD Foundation, 
Current Operating System: NetBSD 2.99.10 NetBSD 
2.99.10 (GENERIC.MPACPI) #5: Tue Nov  2 00:57:34 EST 2004 i386
Build Date: 03 November 2004
Changelog Date: 29 October 2004
         Before reporting problems, check http://www.XFree86.Org/
         to make sure that you have the latest version.
Module Loader present

This driver was not found with 4.4.0...

(II) LoadModule: "i810"
(II) Loading /usr/X11R6/lib/modules/drivers/i810_drv.o
(II) Module i810: vendor="The XFree86 Project"
         compiled for, module version = 1.3.0
         Module class: XFree86 Video Driver
         ABI class: XFree86 Video Driver, version 0.7
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
         compiled for, module version = 1.0.0
         Module class: XFree86 XInput Driver
         ABI class: XFree86 XInput driver, version 0.4
(II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
         i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G
(II) Primary Device is: PCI 00:02:0

... instead it tried to use the generic "vesa" driver.


> Out of da blue Louis Guillaume aka ( said:
>>I just got a brand new machine at work. A Dell Optiplex (not infront of 
>>it now, so I don't have all the HW info.)
>>I installed 2.99.10 without a hitch and then ran X -configure to get an 
>>initial XF86Config. The problem is - X did not recognize the video 
>>device, so used the generic "vesa" driver and left a half-hearted config 
>>in And although there is no complaint of "no screens" 
>>the display just goes to sleep after X is started.
>>My workaround is to check out the latest CVS from and build 
>>using the standard "make World" deal, installing over the 
>>NetBSD-delivered xsrc. Now everything works, apparently there is a new 
>>driver that recognizes my hardware.
>>Is it possible to set a flag of some sort such that, when I run 
>>./ [...] -x [...] release, it will use the "current" XFree sources?
>>Or, even better, have some kind of CVS tag that causes a checkout of 
>>xsrc to grab the sources from instead of from
>>My initial suspicion is to just replace the "xc" directory in xsrc with 
>>the updated one, but I would not want to break anything.
>>Any advice would be most appreciated.
>>Thanks very much,
> #:D