Subject: Re: not enough ptys
To: None <>
From: Alexey G. Khramkov <>
List: current-users
Date: 10/21/2004 10:42:36 (Christos Zoulas) writes:

> In article <20041020004255.GB3031@bee>,
> Rui-Xiang Guo <> wrote:
>>Hi, all.
>>I just installed the new world with the xfree86, then I run
>>startx with icewm. When I tried to fire up the xterm, nothing happend.
>>It just printed some error messages on console -
>>xterm: Error 32, errno 2: No such file or directory
>>Reason: get_pty: not enough ptys
>>I noticed that we have a new frame in /dev. We mount it as mfs.
>>Do I just simple type 'sh MAKEDEV all' in /dev or is there any other
>>correct method to fix it?
> If you see an mfs /dev this means that you forgot to populate /dev when
> you installed (or you're doing this on purpose). Either way, you should
> either make xterm setuid (not recommended) or create /dev/ptm and /dev/ptmx.
> christos

Thanx for answer, I have got the same result on ~week ago CVSed sources,
which was built by common procedure ( tools; kernel=GENERIC;cp {path}/netbsd /netbsd; reboot; -U -x distribution; -U -u -x release; -U -x install=/)
and my xterms refuse to run, the same error output to console.

I didn't read about new frame in /dev, so I guess some paths to ptm*
stay unchanged.

= Alexey G. Khramkov (agkhram) @ Infotech <agkhram{at}mercdev{dot}com> =
= GPG fingerprint : 944D 0C8B 343B 6C8D 50A1  061A E2DA 3E11 7765 6B47 =