Subject: Re: does anyone have the Xorg X server from pkgsrc working w/
To: Harry Waddell <>
From: Juan RP <>
List: current-users
Date: 10/20/2004 08:46:04
Content-Type: text/plain; charset=US-ASCII
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

On Tue, 19 Oct 2004 15:43:06 -0700
Harry Waddell <> wrote:

> I'm running i386 -current and I recently recompiled all my packages with 
> X11_TYPE=xorg in my /etc/mk.conf. 
> Everything built with minimal coaxing, but after the install, my keyboard
> doesn't 
> work as an input device with any x clients, although CTRL-ALT-BSPACE will kill
> the server.
> at the end of /var/log/Xorg.0.log are the lines:
> (II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
> (II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
> Unknown wskbd type 0
> I get the same result using the old keyboard and the new kdb driver. 
> Changing the keyboard from usb to ps/2 also has no effect. [not surprising]
> here's the keyboard input section of /etc/X11/xorg.conf:
> Section "InputDevice"
>         Identifier  "Keyboard0"
>         Driver      "kbd"
> EndSection

My "InputDevice" section is just the same.
> Has anyone had sucess with the Xorg server, or alternatively, has anyone else
> run into this, or a
> similar problem? I'd really like to know if this is a general problem, or just
> some localized
> stupidity on my part.

I'm using it since 6.8.0 was released, on NetBSD/i386 -current, it's working
without any problem.

I remember some problem about mouse/keyboard not working when my kernel wasn't
built with the option "options         WSDISPLAY_COMPAT_RAWKBD ".

Content-Type: application/pgp-signature

Version: GnuPG v1.2.6 (NetBSD)