Subject: Vesa driver in XFree86 (was: Re: Xfree86 errors on 2.0)
To: Matthias Scheler <>
From: Richard Rauch <>
List: current-users
Date: 08/14/2004 15:24:45
The short summary: I recall Vesa working very well on NetBSD a year

If memory serves, the Vesa driver was the only usable driver for
my ATI card last fall (almost a year ago).  I had to manually select
it since the auto configuration screwed up and chose a driver that
apparently did special hacks to make itself slow.  (^&  The default
chosen driver was so slow that you could see it filling horizontal
lines.  The sugary GNU/LINUX installer took forever with all of
its overdone graphics on that slow driver.  Because the GNU/LINUX
install "hid" the relavent config files, I just had to live with
terrible performance there, but on NetBSD I tried alternate drivers,
and found that Vesa performed very nicely.

(The Vesa driver turned in some 1100 or 1300 fps with glxgears on
NetBSD.  Since then I've upgraded NetBSD and X a few times, and
have never been able to top about 600fps, and usually wind up with
about 300fps or 400fps.  A more recent GNU/LINUX install is now
doing DRI with the card (and a decent ATI-specific driver), but
still can't top about 500fps or so.  I gather that the glxgears
demo is not really well-suited to hardware acceleration, so
outperforming DRI on glxgears is not terribly amazing.)

I believe that X is now able to use an ATI-specific driver for this
card, but I have never been able to get performance quite as good
as I had with Vesa last November.  (This is on an AMD64.  Someone
else with a similar ATI card reported similar performance drops,
though I think that he was using an i386.  I *have* tried Vesa
again.  Either X degraded, or something about my NetBSD box
changed to limit the performance that X could achieve.)

Again, this is from memory, which isn't as good as I remember it
being.  (^&

  "I probably don't know what I'm talking about."