Subject: bootstrap from -current and 2.0 fails on Shuttle FV24
To: None <>
From: Laine Stump <>
List: current-users
Date: 08/08/2004 19:36:15
I have a Shuttle FV24 motherboard (Socket370 with VIA chipset circa early 
2002) which has been running post-1.6 for a couple years now. I decided it 
was time to upgrade, so I burned a 2.0 beta ISO I found somewhere onto a CD 
and tried booting that. Unfortunately I don't even get up to the "starting 
in 5 4 3 2 1" prompt - as soon as the BIOS says "Boot from CDROM", the 
screen clears and after a few flashes, the BIOS POST restarts. So I made 
boot floppies from the 20040715 -current snapshot on releng - nearly the 
same results, except this time things happen slow enough that I can see:

	NetBSD/i386 ustarfs primary bootstrap

on the screen for a few seconds before it goes blank. I then tried the 
latest 2.0 beta snapshot boot floppies from releng (0804 I think) and got 
the exact same results. (I also tried the bootlap and boottiny from each of 
those snapshots, with the same results). As a sanity check, I made 1.6 boot 
floppies from the latest snapshot of that branch on releng, and these 
booted with no problems.

Is there anything I can do to collect more data on this problem that might 
help someone debug it?

For now, it's looking like I'll need to put 1.6 boot blocks onto this 
machine to get it to boot - do 1.6 bootblocks have any problems with 
booting on a 200GB disk that has NetBSD in the last 150GB? (in other words, 
should I even try to install my new 200GB drive as primary, or just make it 
a secondary and live with the extra heat of a 2nd disk?) For that matter, 
can -current do that? (the motherboard BIOS does support 200GB disks - I 
just upgraded it the other day).