Subject: Re: help needed with X config
To: Steve Bellovin <>
From: Greg 'groggy' Lehey <>
List: current-users
Date: 07/03/2004 14:49:36
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

On Wednesday, 23 June 2004 at 21:11:11 -0400, Steven M. Bellovin wrote:
> I'm having trouble configuring X for a new machine.  I've attached my
> XF86Config and the Xlog output.  The config file is identical to the
> previous one I had used (with the same monitor), with the exception of
> the Device section, which I took from the file generated by the
> -configure option.  The monitor specs can be found at
> I'm trying to run at 1280x1024, 16 bpp.  Windows XP does it just fine,
> and the monitor does indeed claim to be running at 91.1 Hz horizontal.
> But XFree86 insists that it can't find a usable configuration.  I tried
> adding HorizSync and VertRefresh lines to the Monitor section (not
> shown below); that didn't help.
> The log file clearly shows that Mode 49 is 1280x1024x16, so the
> resolution and depth are supported.  I freely confess I don't
> understand the rest of the fields for the mode descriptions.
> I'm running a very up-to-date -current X server.

You don't say what goes wrong, and neither (AFAICT) does the log file,
but it does point to a problem with the mouse.  What happens when you
try to start?  Does xf86cfg do anything useful?

Note: I discard all HTML mail unseen.
Finger for PGP public key.
See complete headers for address and phone numbers.

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.0 (FreeBSD)