Subject: Re: NetBSD pkgsrc/net/ppp-mppe on -current (2.0E)
To: None <>
From: Andrew Reilly <>
List: current-users
Date: 05/20/2004 15:57:19
Sorry for the noise and self-followup.  I think that I've fixed my
problem, and it turns out that I hadn't provided you with enough
information to help me anyway.

On Thu, 2004-05-20 at 13:53, Andrew Reilly wrote:
> mppe.o: modload: error initializing module: Program version wrong

What I hadn't noticed is that at the same time, the console said:

LKM 'mppe': environment compile options mismatch - LKM 'DIAGNOSTIC', kernel ''

So, I just hunted down DIAGNOSTIC, and found the relevant use in
patches/patch-cb, which was adding that as a define to CFLAGS in
netbsd-1.4/Makefile.  I haven't got options DIAGNOSTIC turned on in my
kernel (maybe stupid?), so I edited this out, re-built, and now the LKM
has loaded nicely.  I haven't tried to use it yet, but thought that I'd
mention this, in case someone else gets similarly bitten.


Andrew Reilly <>