Subject: NetBSD pkgsrc/net/ppp-mppe on -current (2.0E)
To: None <>
From: Andrew Reilly <>
List: current-users
Date: 05/20/2004 13:53:30
Hi there,

I'm in the process of trying to replace a FreeBSD box with a NetBSD one,
as my network gateway, router and what-not.  Previously this box was
just used as a print server and NetBSD experimentation box.  One
consequence of that is that it's running quite recent current 2.0E,
built just now, from sources cvs'd a day or so ago.

I'm making pretty good progress, but have become stumped on the PPTP VPN
link that I need, to stay in touch with my work's main office.  On
FreeBSD I used mpd, which is also a PPP derivative, and that worked
nicely, most of the time.

I'm following the instructions at
and that has had me build the pkgsrc/net/ppp-mppe package.  That seemed
to go swimmingly well, but attempting to load the resulting LKM into the
kernel just results in the message:

mppe.o: modload: error initializing module: Program version wrong

I've had a short poke through the sources, and it seems that the last
version tha twas explicitly supported was 1.4.  However, the web-page
mentioned above says that it worked on at least NetBSD 1.6.1.

Any thoughts on what I need to frob to make the port interact happily
with the LKM on my kernel?

I'm about to try the "-f" option to force modload to load the module
as-is, but pretty obviously I don't want to have to do that as a general

What documentation should I start to look at, to get into this?  The
lkm(4) man page doesn't have much in the way of detail.  I would have
thought that the lkm API in <sys/lkm.h> would have been used when
building the module, which should have sorted out this sort of issue at
the time.  Obviously there's other types of compatability to deal with.

Thanks for any help you can provide,

Andrew Reilly <>