Subject: Re: problems with cvs update from 1-6 to -current and then 2-0
To: Matthias Scheler <>
From: David Frech <>
List: current-users
Date: 05/15/2004 23:24:38
Matthias Scheler wrote:
: In article <20040514235418.GA1334@stubb>,
: 	David Frech <> writes:
: > More recently I "updated" (downdated ;-) the _same_ tree to netbsd-2-0 in
: > the following way:
: > 
: >   root@queequeg /usr/src# cvs update -dP -r netbsd-2-0
: You have to use "cvs update -APd -rnetbsd-2-0". And you should use
: "make cleandir" before updating.

I tried this. First I tried "make cleandir" and then my find trick to see
if there were any Tnetbsd-1-6 files in the tree; they were all still there.

Then I tried cvs update -APd -r netbsd-2-0, and ran the same find ... and
got the same results: still a bunch of Tnetbsd-1-6 files in the tree.

So, I decided to try an experiment. I checked out a 1-6 tree and then
updated it to 2-0:

  cvs update -dP -r netbsd-2-0

and ran my find, and saw _no_ Tnetbsd-1-6 files. So I'm not sure how, but I
must have really borked my other tree, or somehow really confused cvs. I
was hoping for a reproducible case; no such luck.

Anyhow, thanks Mattias.

- David