Subject: Hang when bringing up ne0 on -current
To: None <>
From: None <>
List: current-users
Date: 05/07/2004 13:17:13
I downloaded an install floppy from and tried it on my 
Laptop (Intel 132Mhz, 24MB ram, 1GB hdd).

When trying to configure the pcmcia card to installation via ftp the 
system seems to just 'hang' ( and i use that term loosely. I suspect its 
being delay()'d).

The pcmcia card is a SMC 8040TX.

I've tried this card with NetBSD 1.6.1 and i have the same kind of problem 
when booting a GENERIC kernel. After digging through i82365_isasubr.c i 
suspect theres a bug when pcic_isa_chip_intr_establish is called, because 
i get the "pcmcia0: card irq 11" message.. and then it just waits.

I do realise i'm being kind of vague here, if you could offer any advice 
or direction that would be a great help. I'll provide any further 
information that anyone may require, just email.




"It's not that you should never play with fork(), you just have to be 
cautious. It's kind of like sword-swallowing; if you're careful, you won't 
disembowel yourself." -- Brian "Beej" Hall