Subject: Re: vs3100/3x SCSI broken in 2.0_BETA?
To: Havard Eidnes <>
From: Paul Kranenburg <>
List: current-users
Date: 04/26/2004 17:44:56
> > > Also sometimes the kernel marks the disks as offline during
> > > probing and the installer then can't find any disks.
> >
> > Mine are marked as offline, but they seem to work anyway, for normal
> > use, I have not tried sysinst.
> >
> > sd0 at scsibus0 target 0 lun 0: <DEC, RZ24     (C) DEC, 211B> disk fixed
> > sd0: drive offline
> > sd0: async, 8-bit transfers
> > sd1 at scsibus0 target 2 lun 0: <DEC, RZ24     (C) DEC, 211B> disk fixed
> > sd1: drive offline
> > sd1: async, 8-bit transfers
> I also noticed this when I tried to install a 2.0C snapshot about a
> week ago, and I found it somewhat odd.  This is also annoying in
> that the capacity isn't probed or displayed.  I wonder if this
> "sd<n>: drive offline" thing is something which is actually spurious
> or misleading, is it the drive which requires a "start drive"
> command, or something else?

see scsipi_base.c, rev 1.102.

I have pending query with Manuel about this issue:

the initial test unit ready
when attaching a drive returns an EIO error resulting in a "drive offline"
message. This is because the drive issues a "unit attention" after
the initial scsi bus reset of the adapter. Previously, this condition
would just generate an ERESTART.  But in the probe phase, XS_CTL_DISCOVERY
is used which forces the # of retries to 0, causing the unit attention
to return EIO and hence, the test unit ready to fail.