Subject: build install failing unless tools rebuilt again
To: None <>
From: Art Lemasters <>
List: current-users
Date: 04/14/2004 08:24:59
When I run

./ -u -x -D /usr/mydestdir distribution

, that works fine. But is it deleting some tools files? Because
when I run

./ -u -x -D /usr/mydestdir install=/

, it fails, unless tools are rebuilt after building the
distribution. If I rebuild the tools again after running the first
command above, the install works fine.

Background info - cleaning up old directories, etc.

   make cleandir is done in each of the src, xsrc and pkgsrc directories.
Then the CVS update is done.

   Before the build, the /usr/obj and /usr/mydestdir are deleted with
rm -r, then a mkdir for each to assure the two empty directories
before building. Then ./ tools is done.  Then, old kernel
config files are wiped with

rm -r /sys/arch/i386/compile/obj.i386/MYKERNEL


./ kernel=MYKERNEL

The old kernel in the root directory is replaced with a new one, then
the machine is rebooted.

...then the build.

   BTW, a very minor note on something else...  When updating pkgsrc,
CVS doesn't know what to do with the README files and doesn't do
anything with those. This could be (although I'm not sure) because
I downloaded the pkgsrc directory first as a tarball some months
ago.  Or maybe it's supposed to work that way.