Subject: Re: -x not working with readonly /usr/xsrc
To: Luke Mewburn <>
From: Mason Loring Bliss <>
List: current-users
Date: 04/14/2004 13:38:46
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Wed, Apr 14, 2004 at 05:49:08PM +1000, Luke Mewburn wrote:

> Do you have a stale dependency file around?=20
> Have you tried removing/cleandir-ing your objdirs and trying again?

No, my method of building guarantees a clean directory tree each time

I've actually isolated the problem, but I haven't finished my test build
yet, so I haven't yet sent in a PR. What is happening is that my build
environment is *too* clean. I run through "env -i", with only
"PATH=3D/bin:/usr/bin" set. What is happening is fc-cache fails to function
if there is no "HOME" environment variable set. It can be set to something
non-existent and/or nonsensical, but it *must* be set, or fc-cache will

Builds complete on TGM because the environment is not stripped away before
the build, thus leaving random things in that happen to make the build work.

I'll be sending in a PR and a note to releng-2-0 later today, once I've
had a chance to look at the fc-cache source and hopefully whip up a patch.

    Mason Loring Bliss  They also surf who
awake ? sleep : dream;     only stand on waves.

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (NetBSD)