Subject: Re: -current build release fails
To: MLH <>
From: Bill Studenmund <>
List: current-users
Date: 02/25/2004 12:46:17
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, Feb 22, 2004 at 01:31:45PM -0600, MLH wrote:
> >=20
> > > $ /usr/src/ -r -U -u -m i386 -D /opt/build/i386 -O=20
> > > /opt/build/i386/obj
> > > -T /opt/build/i386/tools -R /opt/snapshot/i386 tools release
> >=20
> > If you do this, make DESTDIR a subdir of the object directory, not the=
> > opposite.
> Didn't work. However, after the recent discussion regarding MAKEOBJDIR
> vs. MAKEOBJDIRPREFIX, I tried -M instead of -O and it worked.

Note: if you used -O before, you probably have symlinks all over your=20
tree. You'd need to zap them before a different -O selection would work.=20
-M works as it causes make to not look at existing obj dirs at all.

The main thing Matt was trying to say was that you can't out stuff under=20
DESTDIR. So both your -O and -T selections were wrong. DESTDIR (-D) is=20
supposed to be a file system that looks EXACTLY like the installed NetBSD=
you're building. obj and tools dirs aren't supposed to be there, thus your=

> $ /usr/src/ -r -U -u -m i386 -D /opt/obj/i386/build -M /opt/obj/i=
386 -T /opt/obj/i386/tools -R /opt/snapshot/i386 tools release
> So it took both moving the builddir under the objdir and using
> MAKEOBJDIRPREFIX instead of MAKEOBJDIR to get it to build a release
> now.
> Next question: what is needed to get it to build xsets now, since
> 'make release snapshot' only builds empty xset files from /usr/xsrc
> now and adding the '-x' option to above doesn't work either?
> $ /usr/src/ -x -r -U -u -m i386 -D /opt/obj/i386/build -M /opt/ob=
j/i386 -T /opt/obj/i386/tools -R /opt/snapshot/i386 tools release

Try -X /where/xsrc/files/are. Also you need to have the src/x11 bits=20
around too. The src/x11 bits are the build linkage, and the xsrc bits are=
the actual X soruces.

Take care,


Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (NetBSD)