Subject: Re: Build stalls at tools/texinfo
To: None <>
From: Garry Roseman <>
List: current-users
Date: 02/22/2004 18:37:00
On Saturday 21 February 2004 03:51 pm, walt wrote:
> walt wrote:
> > After updating sources today I get this on two -CURRENT boxes:
> >
> > #      link  uudecode/uudecode
> > cc -O -I/usr/src/tools/compat/obj -I/usr/src/tools/compat/obj/include
> > -I/usr/src/tools/uudecode/../compat -DHAVE_NBTOOL_CONFIG_H=1
> > -D_FILE_OFFSET_BITS=64 -D_NETBSD_SOURCE    -o uudecode uude
> > code.lo -L/usr/src/tools/compat/obj -lnbcompat -lz
> > dependall ===> texinfo
> Sorry, my mistake:  the problem is with texinfo, not uudecode.  I can
> reproduce the problem with:
> # cd /usr/src/tools/texinfo
> # make  (hangs forever with a zombie ksh process)
> Anyone else seeing this?

Yes, isn't everyone??  I get exactly this behavior, a zombie ksh process
while compiling tools/texinfo that hangs the system.  It is impossible to
recompile the system using "make buildworld" or "sh build"
on an i386 1.6ZK that was built on Feb 20th with any source tree that
has been available since that time until now (evening of Feb 22nd).

This seems to place me at an impass; it is impossible to rebuild my
way out of this dead end.  

Should I install the binary/tar_files that were released on Feb 19th?
Does anyone know that that system is ok?

I have been trying to build a current system onto a VIA EPIA CL10000
mini-itx system for the past week and have yet to get so far as being
able to install packages. I was very pleased with the initial install.  It
went smoothly, but since then I have seen x11-links failure, the pagedaemon 
deadlocks, and the hang while trying to upgrade my way out of the other
two problems.

Garry Roseman
Memphis, Tennessee