Subject: Re: -current build release fails
To: Matt Thomas <>
From: MLH <>
List: current-users
Date: 02/22/2004 13:31:45
> > $ /usr/src/ -r -U -u -m i386 -D /opt/build/i386 -O 
> > /opt/build/i386/obj
> > -T /opt/build/i386/tools -R /opt/snapshot/i386 tools release
> If you do this, make DESTDIR a subdir of the object directory, not the 
> opposite.

Didn't work. However, after the recent discussion regarding MAKEOBJDIR
vs. MAKEOBJDIRPREFIX, I tried -M instead of -O and it worked.

$ /usr/src/ -r -U -u -m i386 -D /opt/obj/i386/build -M /opt/obj/i386 -T /opt/obj/i386/tools -R /opt/snapshot/i386 tools release

So it took both moving the builddir under the objdir and using
MAKEOBJDIRPREFIX instead of MAKEOBJDIR to get it to build a release

Next question: what is needed to get it to build xsets now, since
'make release snapshot' only builds empty xset files from /usr/xsrc
now and adding the '-x' option to above doesn't work either?

$ /usr/src/ -x -r -U -u -m i386 -D /opt/obj/i386/build -M /opt/obj/i386 -T /opt/obj/i386/tools -R /opt/snapshot/i386 tools release