Subject: Re: multiprocessor i386 1.6ZH system crash
To: None <>
From: Lubos Vrbka <>
List: current-users
Date: 02/15/2004 19:53:41
> Have you tried whether you can get into ddb remotely before? It should
> work at any time, not just during a crash. 
yes, sure. tried it several time, ~# in tip on my serial console gets me into 
the ddb prompt, so it surely works.

> ddb.onpanic is useless in this
> case because it's (probably) a deadlock and the kernel doesn't notice
> that it's dead (well, who ever did?). You must set ddb.fromconsole=1 (with
> sysctl). OTOH, you're lock problem might be worse and if the IRQ for
> the UART is blocked, you're ... having a problem. Just in case, try
> setting hw.cnmagic to something easy to type like:
> 	sysctl -w hw.cnmagic=backdoor
my hw.cnmagic is set as written above (i.e. \x27\x02) - it's easy to type enough 
(~#) :-). should i still change it?

> I've seen it in 1.6ZJ as well - but I can't know whether it's really the
> same problem as yours. Actually, I recently had two different crashes for
> different reasons, the latter being rather network related.
i'll probably update and then wait for 1.6ZK - but i think if the problem will 
be solved, it will be just matter of fortune as we don't know what and why 
causes it... the only thing we now is the problem lies somewhere in the MP code, 
as SP kernel never hang like this for me.

maybe it's time to switch my computer to single processor for some time... :(