Subject: Re: gcc unable to make executables ?
To: Daniel Carosone <>
From: Martin Weber <>
List: current-users
Date: 02/09/2004 10:51:05
On Mon, Feb 09, 2004 at 08:20:38PM +1100, Daniel Carosone wrote:
> On Mon, Feb 09, 2004 at 09:08:47AM +0000, Mark Kirby wrote:
> > Yeah i see the same thing. I just upgraded from 1.6.1 to sources from 
> > saturday and tried to install the new kde and i got exactly the same errors.
> time to update again, this was fixed not too long ago.

Uh huh ... that's just not true.

# ident mk/compiler/
     $NetBSD:,v 1.47 2004/02/08 03:34:20 jlam Exp $
# cd lang/ruby-base
# make install
checking for gcc... gcc
checking whether the C compiler (gcc -O2  -Wl,-R/usr/pkg/lib -L/usr/pkg/lib) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
*** Error code 1

make: stopped in /usr/pkgsrc/lang/ruby-base
# cd work/ruby-1.6.8
# cat config.log
configure:785: checking for gcc
configure:898: checking whether the C compiler (gcc -O2  -Wl,-R/usr/pkg/lib -L/usr/pkg/lib) works
configure:914: gcc -o conftest -O2    -Wl,-R/usr/pkg/lib -L/usr/pkg/lib conftest.c  1>&5
gcc: installation problem, cannot exec `cc1': No such file or directory
configure: failed program was:

#line 909 "configure"
#include "confdefs.h"


# cd ../.buildlink
ksh: cd: /usr/pkgsrc/lang/ruby-base/work.i386/.buildlink - No such file or directory

I've had the exact same problem yesterday with mutt, but 1.47 fixed it. What's broken
NOW ? (and please keep in mind that anoncvs needs a day itself to be up-to-date!)

# uname -sr
NetBSD 1.6ZI

pkgsrc updated yesterday.

What info do you need else ? Why can't such big changes be tested with a bulk build? :(