Subject: Now I've done it! Hosed up my boot blocks!
To: #List NetBSD current users <current-users@NetBSD.ORG>
From: Paul Goyette <>
List: current-users
Date: 01/23/2004 23:25:18
Having successfully upgraded to 1.6ZH (as of a couple days ago), I
figured I would be brave and update my boot blocks, too.  They had
not been updated in at least two or three years!

So, grovelling through man pages, I figured out that I should do:

1. fdisk -c /usr/mdec/mbr sd0
2. cp /usr/mdec/boot /boot
3. installboot -v -o timeout=5 /dev/rsd0a /usr/mdec/bootxx_ffsv2

Well, I tried to reboot the machine.

As far as I can tell, step 1 worked because it didn't try to boot from
floppy.  And I'm pretty sure step 2 worked because it identified itself
as bootxx_ffsv2.  But step 3 apparently failed because it couldn't find

I don't understand this, since the file is obviously there when I do a
ls -l /boot it tells me the file is 53564 bytes long.

I was able to recover by booting an antique (1.3? 1.4?) install floppy
and then interrupting the timeout and telling it to boot hd0a:netbsd.

But I would really like to fix up my hard drive so I don't have to keep
a floppy around.

Where did I go wrong?  And can I fix it?

Thanks again for any clues.

|   Paul Goyette   | PGP DSS Key fingerprint: |  E-mail addresses:   |
| Network Engineer | FA29 0E3B 35AF E8AE 6651 |   |
|  & World Cruiser | 0786 F758 55DE 53BA 7731 | |