Subject: umass0 and USB floppy broken for me
To: NetBSD-current <>
From: Bryan P <>
List: current-users
Date: 01/23/2004 13:41:53

I am running -current dated yesterday (NetBSD 1.6ZH i386) and am having
trouble with the USB floppy support.  The device is recognized and
configured, the lights come and and drive head moves during access, but I
only get "Device not configured" from the kernel.


My logs show:

Jan 23 13:27:31 neptune /netbsd: uhub1: port error, restarting port 1
Jan 23 13:27:33 neptune /netbsd: umass0 at uhub1 port 1 configuration 1 interface 0
Jan 23 13:27:33 neptune /netbsd:
Jan 23 13:27:33 neptune /netbsd: umass0: Sony USB Floppy Drive, rev 1.10/4.01, addr 2
Jan 23 13:27:33 neptune /netbsd: umass0: using UFI over CBI with CCI
Jan 23 13:27:33 neptune /netbsd: atapibus1 at umass0: 2 targets
Jan 23 13:27:33 neptune /netbsd: sd0 at atapibus1 drive 0: <SONY, USB-FDU, 4.01> disk removable
Jan 23 13:27:38 neptune /netbsd: sd0: 1440 KB, 80 cyl, 2 head, 18 sec, 512 bytes/sect x 2880 sectors
Jan 23 13:27:58 neptune /netbsd: sd0: dos partition I/O error
Jan 23 13:28:48 neptune /netbsd: sd0: dos partition I/O error

The "dos partition I/O errors" are in response to my attempts to mount a
DOS-formatted floppy.  I've tried /dev/sd0a through /dev/sd0d (the latter
being what I used to use when this was working in previous versions).  I've
also tried formatting the disk and writing characters to it.  All fail

% newfs_msdos /dev/rsd0d
/dev/rsd0d: 2840 sectors in 355 FAT12 clusters (4096 bytes/cluster)
MBR type: 1
bps=512 spc=8 res=1 nft=2 rde=512 sec=2880 mid=0xf0 spf=2 spt=18 hds=2 hid=0
newfs_msdos: /dev/rsd0d: Input/output error

Note that in the above example I tried the raw device, but it makes no
difference in the outcome which device I use.  I know the disk is good
because I've tested it in a Linux box.

Any advice would be appreciated!