Subject: Re: problems with wi
To: None <>
From: David Young <>
List: current-users
Date: 01/17/2004 15:08:59
On Sat, Jan 17, 2004 at 02:59:10PM -0600, Emre Yildirim wrote:
> Hi,
> I'm trying to get wireless working at my house.  At work we have a AirPort that runs
> dhcp, and doing dhclient wi0 works like a charm.  I get an IP address and I can
> browse the 'net.
> But at home things are a bit different.  I use WEP and no dhcp, so I pretty much
> have to set the IP manually.  Thus far everything I've tried failed.  First I
> thought I was using the wrong channel, so I tried "chan 1, chan 2 etc." None of
> those options helped.  Then I thought I might be doing something wrong with the WEP
> key, so I changed it to lower case and then uppercase again, didn't help.  I've ran
> out of things to try.  The gateway is correct, and the NIC seems to be 'up,' but
> there is no activity.  The WAP's green lights blink 3-4 times when I up the wireless
> card on the laptop.  After that there is no more activity.  Doing tcpdump -i wi0
> doesn't show any traffic either.
> Another laptop running XP, using the same network key and gateway is working fine. 
> Does anyone know what I could be doing wrong?
> Here's some information:
> /etc/ifconfig.wi0:
> inet netmask nwkey 822FFFB8FF

You have set a 104-bit ASCII key, here. Perhaps you meant to set
a 40-bit hexadecimal key with 0x822FFFB8FF?

You should see more wireless activity if you run
`tcpdump -ne -D ieee802_11 -i wi0'.


David Young             OJC Technologies      Urbana, IL * (217) 278-3933